Whatever discussed in this article is of 05 Oct 2020 data so in future if the data updates like Plesk support any other newer php version then in that case, the article will be updated accordingly.

As mentioned in Plesk KB article at https://support.plesk.com/hc/en-us/articles/360001008334-Which-PHP-versions-are-supported-in-Plesk-17-8-for-Linux-

PHP versions 5.2, 5.3, 5.4, 5.5, 5.6, 7.0, 7.1, 7.2, 7.3 with the latest subversions are supported.

So these are the version supported by Plesk Panel.

https://wordpress.org/about/requirements/ says PHP 7.4 is recommended but is not must.

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.6.20+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

So they are mainly talking about dont have PHP 5.x in the same article as that may be insecure and vulnerable.

In short, wordpress 5.5.1 latest shall work fine with PHP 7.3 too so please have it installed using Plesk application installer and late us know via email at support@webji.services in case any technical issue arises.

Further once PHP 7.4 the newest is supported by Plesk it will be auto updated and available on our servers too in near future.****
Was this article helpful?
Cancel
Thank you!